Debts 1.3.2

Debts 1.3.2 is now available on the App Store. This is an iOS 5 compatible release. You can upgrade to this latest release before or after your iOS 5 upgrade. With this release, iOS 4.3 is the minimum iOS version required to run Debts app.

Debts app on iTunes App Store

Posted in debts

Archive