Routines 2.5.3

Routines 2.5.3 is now available on the App Store. This is an iOS 5 compatible release with bug fixes. You can upgrade to this latest release before or after your iOS 5 upgrade. With this release, iOS 4.3 is the minimum iOS version required to run Routines app.

Routines app on iTunes App Store

Posted in routines